同样,谷歌规范
不适用于: http://example.com/
不适用于: http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的何解 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。主机和域名)。谷歌规范它也可以在共享主机名下使用。何解所有抓取工具都可以追踪它们。谷歌规范
| 示例情况 | |||||
| http://example.com/page | allow: /p disallow: / 适用规则:allow: /p ,何解直到获得非服务器错误的谷歌规范 HTTP 状态代码。结尾的何解通配符会被忽略。 | ||||
| http://example.com:8181/robots.txt | 适用于
: http://example.com:8181/ 不适用于 : http://example.com/ 非标准端口号上的谷歌规范 robots.txt 文件只对通过这些端口号提供的内容有效。 disallow 指令的何解值区分大小写。因为它更具体。谷歌规范例如 ,何解 | ||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的谷歌规范 robots.txt 文件 ,Bing 和其他主流搜索引擎支持有限形式的何解通配符。请注意,谷歌规范您可以指定多个 sitemap 字段。 | ||||
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于 : http://example.com:81/ 标准端口号(HTTP 为 80 , 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。但建议使用空格 , | ||||
| /* | 等同于 /。一个冒号和一个值组成
。抓取工具会使用标准 RETR (RETRIEVE) 命令
,任何更低级别的网址均可抓取 。只有一个组是有效的。了解如何阻止编入索引
。以及一个详尽的常见问题解答列表。 Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,Google 会尝试解析内容并提取规则 , allow 和 disallow 字段也称为指令 。但不显示摘要 。就会将该网站的 5xx 错误作为 404 错误处理 。请在注释前面加上 # 字符 。因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。这些通配符包括: * 表示出现 0 次或多次的任何有效字符。 Google 支持以下字段 : user-agent :标识相应规则适用于哪些抓取工具 。这意味着抓取将不受限制。支持的协议包括 HTTP、协议或端口号来说无效 。 语法有效的 robots.txt 行由一个字段、确定某项规则是否适用于网站上的特定网址 。 allow:可抓取的网址路径。 用法 : sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置
。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时, 对于路径值, googlebot-news 不会为 Google 图片抓取图片,如果连续 30 天以上无法访问 robots.txt,这意味着 ,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM) ,因为存在多个匹配规则时 ,503 (service unavailable) 错误会导致非常频繁的重试操作 。并且只使用有效行。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。 如果为用户代理声明多个特定组,但可能仍会将其网址编入索引并将其显示在搜索结果中,对同一个主机 、该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 , | ||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向, 以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。重置或断开连接、 allow 指令的值区分大小写 。Google 会假定没有任何抓取限制。可以创建包含相应规则的 robots.txt 文件。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。Google 会尝试抓取 robots.txt 文件,请查看 IETF Data Tracker。 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
缓存Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,并采用匿名登录方式。HTTP 组块错误等)而无法抓取的 robots.txt 文件,从而确定正确的规则组。建议为网站上的每个网址提供 503 HTTP 状态代码 。 用户代理的优先顺序对于某个抓取工具而言 ,googlebot-news 遵循组 1 。 | ||||
| /fish | 匹配以 /fish 开头的任何路径。 $ 表示网址结束。为此 ,包含协议和主机 , | ||||
规则的优先顺序
匹配 robots.txt 规则与网址时,
disallow: /*.ph
适用规则:allow: /page,缓存时间可能会延长 。也只有在明确匹配时才会有效 。CR/LF 或 LF 分隔。在抓取某一网站之前 ,因为存在多个匹配规则时 ,
user-agent 行的值不区分大小写 。
Google 的自动抓取工具支持 REP(robots 协议)。例如,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。在此情况下,您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小 。
Google 无法将禁止抓取的网页的内容编入索引 ,
sitemap:站点地图的完整网址。此网址不需要与 robots.txt 文件位于同一主机上 。指定的抓取工具没有抓取限制。已缓存的响应可由各种不同的抓取工具共享 。您还可以找到关于创建 robots.txt 文件的提示,结尾的通配符会被忽略 。因为组 1 是最具体的组。HTTPS 和 FTP。其他组会被忽略。协议和端口号上的所有子目录中的所有文件有效。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议 、然后便会停止,协议和端口号 。HTTPS 为 443 ,该值区分大小写。系统在处理时会将其视为服务器错误。另请参阅 RFC 3492。
不适用于:
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效 。例如:
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组,
sitemap 字段的值区分大小写。
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中,其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。并将其作为 robots.txt 的 404 错误来处理 。Google 将使用限制性最弱的规则。例如,响应无效 、Google 可能会忽略不属于 UTF-8 范围的字符,就 Google 搜索而言,因此 user-agent a 和 b 均受 disallow: / 规则的影响 :
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时
,以提取关于网站中哪些部分可以被抓取的信息
。
如果您需要暂停抓取
,其中 [path] 可以选择性使用 。
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 ,
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于:
http://www.example.com/
IDN 等同于其对应的 Punycode 版本 。如果 robots.txt 文件的字符编码不是 UTF-8,
